AO3 Emails, History, and Search Updates Delayed

Resolved

Our servers have caught up on their backlog. Emails, history, and search updates are now processing as normal!
Posted Jul 05, 2025 - 10:35 UTC

Monitoring

Emails, as well as search and history updates, are currently delayed. No data has been lost: emails will still be delivered and history/search will still be updated, just behind schedule. Thank you for bearing with us!
Posted Jul 04, 2025 - 18:37 UTC
This incident affected: Archive of Our Own.