Email Delays

Update

The email servers continue to catch up, about 83k emails remain in the queue.
Posted Aug 04, 2025 - 12:06 UTC

Update

Our email queue still has about 183k emails to go. We're doing a couple things to try and catch up quicker, but it will still take some time to send all of these emails.
Posted Aug 04, 2025 - 05:47 UTC

Identified

We have identified a problem with our mail servers which is causing delays in email. Emails are being sent as we speak, but it will take some time for things to catch up. Please bear with us!
Posted Aug 04, 2025 - 02:17 UTC
This incident affects: Archive of Our Own.