AO3 Slow Performance

Resolved

The Archive is now operating normally. Thanks for your patience!
Posted May 18, 2025 - 06:08 UTC

Monitoring

We have identified a potential cause of the issue and implemented a fix. We will continue to monitor to confirm that the issue is resolved.
Posted May 18, 2025 - 05:55 UTC

Update

We have taken some steps to improve performance, but we are continuing to investigate this issue.
Posted May 18, 2025 - 04:42 UTC

Investigating

We are investigating slow performance on the Archive.
Posted May 18, 2025 - 02:50 UTC
This incident affected: Archive of Our Own.