[AO3] Delayed AO3 Emails

Resolved

Our servers have caught up on their backlog. Emails are now being sent out as normal!
Posted Jul 28, 2025 - 13:23 UTC

Monitoring

AO3 emails are currently delayed. No data has been lost: emails will still be delivered, just behind schedule. You may also get some duplicate emails. Thank you for bearing with us!
Posted Jul 27, 2025 - 18:48 UTC
This incident affected: Archive of Our Own.