AO3 slowness

Resolved

The slowness and intermittent errors have been resolved.
Posted Jul 13, 2025 - 11:25 UTC

Investigating

Due to database server maintenance, Archive of Our Own is loading more slowly than normal and may occasionally show error messages.
Posted Jul 13, 2025 - 09:05 UTC
This incident affected: Archive of Our Own.